antsle Forum

Welcome to our antsle community! This forum is to connect all antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your antsle and expect a response from our team directly, please continue to use the appropriate channels (email: support@antsle.com) so every inquiry is tracked. 

You need to log in to create posts and topics.

Upgrade to edgeLinux - Complete disaster

I have the same issues. No ssh, but antlets are running, though I can't ssh into any of them. If I run 'ifconfig br0 up' i get access for about 3 pings and then it goes back to not working. Has the support team found a solution to this? I have a dead antsle otherwise. This happened when I ran 'upgrade-antman 0.12.0'

I'm able to stop/start net.br0 service manually after each boot and then ping and ssh will work again. The issue now I get a '502 Bad Gateway' when attempting to connect to the web frontend. Any ideas how to resolve this? Thanks.

Some of the issues mentioned would appear to go beyond the scope of the solution I found but will try my best to give best educated guesses to comments posted after my solution post.

@itsky - I think you were having the same issue as me initially after I was able to get back to the web GUI. You may need to make sure you have routes configured in your /etc/conf.d/net and once you do that, "DON"T CHANGE ANYTHING in the network settings of the web GUI until a better patch for the issue is released as clearly this is starting to not look like an isolated incident. I believe @will is a moderator for Antsle. I don't work for Antsle and am just another user. Another tip might be to get rid temporarily of your bridged connections for your antlets. I needed to delete and rebuild new MAC addresses for mine in the GUI once I got to the web GUI more stable. Initially I noticed I could access the web GUI but my local IP for my antlets quit working and rebuilding the bridge connection resolved that issue.

@tupacalypse187 - Your issue sounds to me like an issue with nginx not starting correctly or bad configuration files Try running "vdir /etc/nginx/virtualhosts" and comparing with any issues during system startup. During boot mine was telling me there were errors with some of mine and was ignoring them but as a precaution I deleted the problematic ones. I'm sorry it's not a great next step but it seems to me like it's connecting to the antsle but not sure where to route internally. A bad gateway at least means you got a response from the server.

I hope this helps guys. I'm probably not going to be following this topic much longer unless an Antsle moderator comments shortly of a better solution than mine. At the moment, I cannot touch any of the network settings inside the web GUI or it will quit working again and have to repeat the steps above. One other weird issue still plaguing me is my antsle is connected to anthill and says it contacted it within a minute but my domain "subdomain".antsle.us only seems to work inside my LAN network. If I try and connect outside my home, it just times out. So clearly it's not a perfect fix, but at least it's functional again for me.

giving it a shot....I will report more soonish

BTW...if you want to use an editor that will not make you want to put a gun to your head...

"emerge nano"

 

on the subject of gentoo.. i found the console command eselect news read to be quite edifying...