Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

You need to log in to create posts and topics.

Upgraded edgeLinux, network is now wonky

I hadn't done anything with my antsle in a while, when I decided to do a couple of projects today. (No antlets or anything on it at the moment) The first thing I did was upgrade edgeLinux, which I did to 0.12.0. I honestly couldn't tell you what it was at before. After I upgraded, I restarted my antsle from antman, and now I can't connect to antman or ssh to any of the ip addresses the antsle is assigned. I checked my router and when the antsle boots up, it is definitely getting assigned 2 ip addresses, but I can't connect to either of them. After trying pretty much everything I discovered I still can ssh to [email protected], however from in there I can't seem to connect to or resolve any domain. I can't even ping my router. net.br0 is started, antman is started. Here is my /etc/conf.d/net:

# ---------------------------
# Configuration for enp0s20f0
# ---------------------------
bridge_forward_delay_br0=0
bridge_hello_time_br0=200
bridge_stp_state_br0=1

bridge_br0="enp0s20f0"

config_enp0s20f0="null"
config_br0="192.168.1.200 netmask 255.255.255.0"

rc_net_br0_need="net.enp0s20f0"

Hello kapunga,

Thank you for your support of Antsle. Would you do me a favor and upgrade your edgelinux to 0.12.1? That is the most recent version and may fix your problems. If the problem persists, please reply back so I can submit a ticket based on this issue.

The following worked for me. Comment the following lines from  /etc/conf.d/net

#bridge_forward_delay_br0=0
#bridge_hello_time_br0=200
#bridge_stp_state_br0=1
Then run:
service net.br0 restart
I also found that "service net.bro restart" has to be ran after a reboot as well, or I see what you are seeing.
-akak

I forgot I wrote this. Shortly after originally posting, got smacked with life and had to put my home projects on the back burner. I'm trying to get back to running this, and things are still strange. I managed to upgrade to edgeLinux 0.12.1, but the network is very up and down. Occasionally it works fine. The anthill daemon seems to ping anthill about once a day, just usually when I am not there. Here's a list of oddities:

I can't connect to the internet from my Antsle, so I can't perform any further upgrades etc. (it does seem to connect once in a while, just usually when I am not there.)

I can't use the antMan web console unless I ssh to [email protected] and forward the port.

I can't just plain ping my router/gateway from my antsle, it just says the host in unreachable:
root@myantsle:~ # ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.11 icmp_seq=1 Destination Host Unreachable

I CAN ping it just fine with -I br0:

root@myantsle:~ # ping -I br0 192.168.1.1
PING 192.168.1.1 (192.168.1.1) from 192.168.1.11 br0: 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.264 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.222 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.217 ms

If I ping it from enp0s20f0, which is the only NIC connected, it's not unreachable, but all the packets are lost:

root@myantsle:~ # ping -I enp0s20f0 192.168.1.1
PING 192.168.1.1 (192.168.1.1) from 192.168.1.11 enp0s20f0: 56(84) bytes of data.
^C
--- 192.168.1.1 ping statistics ---
7 packets transmitted, 0 received, 100% packet loss, time 186ms

Here is my current /etc/conf.d/net:

# ---------------------------
# Configuration for enp0s20f0
# ---------------------------
bridge_br0="enp0s20f0"
config_enp0s20f0="null"
config_br0="192.168.1.200 netmask 255.255.255.0"
mac_br0="ac:1f:6b:02:a5:50"
fallback_br0="null
apipa"
rc_net_br0_need="net.enp0s20f0"
routes_br0="default via 192.168.1.1"

A lot of this sounds too familiar and lead me to much bigger issues. Really test other things out with various antlets, creating, adding additional interfaces, cloning, backups, restore, adding external drives, etc. I went round and round with a good support person, and eventually an engineer had to login and fix all my issues. All started after I upgraded. I'll point that support person to this thread to see if he has additional info to help you.

Thanks. Yeah, this definitely started when I upgraded to edgeLinux and a new version of Antman. Luckily, I actually have no antlets running. I had purged all of them out and was about to start fresh. I'm able to make new antlets just fine. My gut feeling is that some networking configuration is off somewhere.

Okay, progress, it appears that duplicate routes are being created when I run ip route list. If I delete the routes, the internet seems to work, but if I restart the interface, the duplicate routes re-appear. If I create and start an antlet or run a docker container, the routes re-appear. I am at a loss as to what is creating these routes, I assume it is edgeLinux related?

@akak01000101, any luck contacting the support person? I can see what's going on, (extra routes are being created), but I can't tell what is causing it and they are created faster than I can remove them if I try to run an antlet or docker container. Any chance you can tell what files your support person likely edited from you /root/.zshhist?

I pointed him to this thread, and he replied to me saying in early February they expect edgeLinux 2.0 to fix all these network issues some customers are having.

Only thing in my .zshhist file are the commands I attempted, which I mentioned earlier. They came in through the AntAid. I'm guessing it drops them into a special backdoor shell.

Sorry I couldn't be more help. I know the feeling.

-akak

Hmmm.. is my issue related??   see  https://antsle.com/forum/topic/suddenly-lost-all-dns-in-the-antlets-after-domain-change/