Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

Running Home Assistant OS as an antlet

Page 1 of 2Next

I've been trying to go down the path of home automation with Home Assistant, and the recommended path for installation is the custom OS. They provide the KVM image ( but when I try to import it as a template and spin up an antlet using it, it's unresponsive. When I open the VNC console I see the message "Booting from Hard Disk" but it never progresses.

Snooping around the Home Assistant forums hints at things like installing/downloading the necessary firmware files or other virt-install workarounds but because of the antsle's abstraction away from the actual VM management, I'm at a loss for how to fix this.

Anyone have any thoughts or maybe has gotten it running before?

Hi roundaround:

Yes, I'm getting the same error message after importing the qcow2 file.

I'm also curious to see if anyone got this to work.


matterantimatter has reacted to this post.

I installed the windows virtualbox image, on a machine, imported that as a template, and created an appropriate vm from that. I know the template works, because I had it working on a computer on virtualbox. I can try to change the bus to IDE???

No luck! Not SATA, not IDE.


I may have got this to work some time ago.
I'll review my notes and research and let you know!

Thank you,
antsle Support

Did you figure out what you did?

Hi @des000

From when I looked at this last time, I wasn't successful.
However, I'm going to try the other images and see what I can find out.

Thank you,
antsle Support

Any luck? If not, should i give up yet? If i should, what OS should i virtualize it in, hopefully with my machine with 2gb ram. If i do that, how do i also share hard drives (overview)? Truenas wont run. Must i use windows, or will another specialized os do? Best, is on antsle though.

Hi @des000

From the research I've done on this, Home Assistant needs UEFI booting of antlets.
Our nano's version of edgeLinux come with this UEFI on natively.  I am doing some research on how to enable this on our x64_86 platform.

In terms of sharing the drives, you can may be able to use SMB sharing.

Thank you,
antsle Support

Thanks for your comment. This plainly tells me, for now, find another solution, unless you suddenly enabled it all at once in a few days, without too much bugs.

This brings up another question I've had though, which I think is appropriate here. Upgrading. I know how to upgrade, I think. But I never found a clear statement of whether or not, beyond a simple one time, upgrade before, whether the device, I believe antsle one if I remember, but not sure, comes with free upgrades when I don't add a paid plan to it. I have to live with the free plan for now, but just wondering if it takes a paid plan for it to work or not, or the purchase of a new device. I bet I could find what release I'm running, if you need it to do that. Just wondering, because such features would only be in the upgrade, I think. That's OK, if it's out of my reach, but I don't want simply my lack of knowing I can do it, to stand in my way. I only want it when new features come up, if I do it, anyway. Like I said though, can't upgrade my plans now though.

Lastly, I know the protocols to share, either smb or ftp or both would meet my needs. However, what I don't know is if Windows or desktop/server Linux would be the best, or if proxmox at the very least, might run within those specs. And if proxmox can be setup to use those protocols in a web GUI way. Truenas, if it would run, would've been perfect for that machine. I want most features to share the drive, but want to run home assistant also. I don't want to run it unvirtualized, because of wasted resources. Virtualbox would work, since your guy's won't, but I don't know what OS is best to run it on for now.

Since yours won't work, and unvirutalized wastes space, i am down to proxmox (which I've never tried to date either), I don't know if they have a free plan, or down to Linux or Windows. First to narrow down, is can proxmox do it then, on those specs. Will it work and do they have the smb and ftp sharing, or do I need the other choices.

Page 1 of 2Next