Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

new Ubuntu 18.04 LXC Templates - using netplan instead of ifupdown

new Ubuntu 18.04 LXC Templates - using netplan instead of ifupdown

network bridging for ubuntu in documentation, antsle, and edgelinux need to be updated with instructions for netplan configuration.

This link can guide you through the basics of Netplan: https://www.linux.com/learn/intro-to-linux/2018/9/how-use-netplan-network-configuration-tool-linux

If you are trying to add a DHCP interface that can be accessed by other hosts on your network:

Edit /etc/netplan/10-lcx.yaml to look like the following:

network:
  version: 2
  ethernets:
    eth0: {dhcp4: true}
    eth1: {dhcp4: true}

You can test your configuration with the following command:

sudo netplan try

if everything works, you can then apply the configuration:

sudo netplan apply

 

thanks for your reply..... I have dealt with it myself for my purposes.....  My point, is that the Official Antsle Documentation for network bridging needs to be updated.

I'd like to bump this topic because I can't get it to work. I've been googling a lot and netplan isn't a very intuitive tool.  It's also not installed by default on the ubuntu_1804_LNX antlet template.

I've tried the simple steps provided above by @captainmccrank, but it didn't work for me.

Is there anybody who has gotten this to work and is willing to share their easy-to-follow steps?

Thanks!

@jwdenzel

I was able to get this to work. I'm guessing when you set it up as above you have multiple default routes? That was my problem, and the extra default route prevented me from connecting directly to my antlet from anywhere outside my local network.

[email protected]:~$ ip route list
default via 10.1.1.7 dev ens3 proto dhcp src 10.1.1.11 metric 100
default via 192.168.1.1 dev ens8 proto dhcp src 192.168.1.15 metric 100
10.1.1.0/24 dev ens3 proto kernel scope link src 10.1.1.11
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown
172.19.0.0/16 dev br-25a85cdd81e9 proto kernel scope link src 172.19.0.1
192.168.1.0/24 dev ens8 proto kernel scope link src 192.168.1.15
192.168.1.1 dev ens8 proto dhcp scope link src 192.168.1.15 metric 100
[email protected]:~$

I was able to solve this problem by setting up netplan to ignore routes from dhcp on the ens3 interface:

[email protected]:~$ cat /etc/netplan/50-cloud-init.yaml
network:
    ethernets:
        ens8:
            dhcp4: true
        ens3:
            dhcp4: true
            dhcp4-overrides:
                use-routes: false
    version: 2
ubuntu@ubuntu:~$

This removed the extra route and I was able to connect to my antlet from outside.

Quote from doug.knowles on July 5, 2019, 11:48 am

thanks for your reply..... I have dealt with it myself for my purposes.....  My point, is that the Official Antsle Documentation for network bridging needs to be updated.

For anyone else searching the forums: I found the new documentation updated for this. Here is the new link: https://docs.antsle.com/networking/bridge