Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

How to resize the disk of a virtual machine once created

How do I  change the effective size of a virtual machine? Here is the scenario:

I created a Windows server virtual machine and attempted to run the updates before activation. It keeps failing in need of more space, and when I go into the settings on the dashboard there is no option to resize it from the initial 20 GB allocated. I can change the Virtual size but not the effective size, any solutions or suggestions? There is a screenshot attached for better understanding

Uploaded files:
  • antsle.PNG

Hey @otoure!

Please check out this article:

Make sure the antlet is shut down before resizing. Once you resized the virtual drive, start the antlet again and resize your partition to make use of the newly available space. You can use the Windows-own "Disk Manager" for that. Simply right-click your partition and select the `expand` function from the menu. (check screenshot for details, please note that your partition layout may look very different).



Uploaded files:
  • extend-volume-windows-7_6.png

Thank you so much @mpbaum, you are a life-saver. I have been wracking my brain trying to figure this out and here you offered the solution, easy and simple.

Glad I could help!


I tried to follow the instructions to extend my windows C:.

Shutdown antlet
Updated antlet virtual disk to 150GB from 100gb
restarted the antlet
opened "Disk Manager", but the "extend volume" is greyed out.

any ideas?

Hi All

I worked it out in the end...

When I resized the antlet virtual disk it put it at the end of my partitions so the drive looked like the image attached...

The unallocated space was at the end, when i right clicked on C: extend drive was greyed out, I installed Niubi(free) to fix it.. Here is an explanation video

vmware windows 11 expand disk - Google Search

All good now i just thought i would post it, if others ran across this issue.


Uploaded files:
  • Drive.png
daniel.luck has reacted to this post.

Hi @kryten

Thanks for sharing this tip!

antsle Support