Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

VNC no Mouse Cursor

12

When I open the console for a kvm (any flavor) I cannot see the mouse cursor. I used to would click Advanced > Local Cursor and it would be there. Seems after the last couple of releases that option is no longer available.  The mouse still clicks, just no way to see where it is on the screen.  You can see in the 2nd screen shot that the workspace 2 is where the mouse is currently located as it waits for click.  But you cannot see the cursor.

Uploaded files:
  • nomouse.jpg
  • nomouse2.jpg

Hi spollock:

Can you let us know what OS and browser you are using?  I tried using Chrome and Firefox on Win-10 as well as Chrome OS, but I couldn't replicate the error.  I was using testing with Win10StdGui template.

My workstation is Windows 10 and I use chrome. The KVMs are different flavors of linux. This particular one is the Debian 11 KVM template that yall recently put available.  I also have this issue with other debian, ubuntu, CentOS templates.  I will build a quick windows kvm and check that too

Hi spollock:

Thanks for sharing.

Most of our Linux KVM templates don't have any GUI.  Did you install DE (Desktop Environment)?  The Kali templates have GUI built-in.

I'll be doing some testing on our Linux KVM's as well.

 

well the thing took a dump while I was uncompressing the Windows 10 template.   Now all I get is this... I guess its time to do something else

Uploaded files:
  • nogo.jpg

...working on it

 

Hi spollock:

Hope everything is OK!

I'll continue testing with Debian 11.

Hi spollock:

I performed some testing with Chrome and Firefox using NoVNC with Debian 11 antlet and XFCE Desktop.

I had followed instructions here to install XFC Desktop Environment:

Install XFCE in Debian 10

The cursor did get hidden when I took screenshot, but I was able to navigate the GUI without any issue.  I did notice some artifacts in the NoVNC control panel on the left in Chrome but not with Firefox.  See screenshots below.

Uploaded files:
  • debian_11_chrome_os.png
  • debian_11_chrome_win10.png
  • debian_11_firefox_win10.png

Thanks for your work on this.  I'll try it out when I get time

Thanks

 

I'm having this issue on a fresh install of Ubuntu 20.04.03 from the ISO image.  I also have the broken image artifacts from NoVNC that @daniel-luck noted.

 

I tried installing XFCE, but that didn't work either.

12