Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

Understanding ports for local Subsonic

Hi folks:

I am using a Debian lxc setup build on antlet, installed a lamp stack and can see those files properly.  I was attempting to install subsonic and although it is showing properly in the system I can't seem to get a browser to access it. I am foggy on ports.  Using their standard 4040 yields nothing. Any tricks on how to access this from a browser?

I'm having a similar problem trying to connect to an Ubuntu LXC antlet on port 5432 (for PostgreSQL). Do I need to add an entry in iptables on the antsle box itself? I've already done so on the antlet, and netstat shows that it's listening, but an nmap on an outside server shows that it's closed (PostgreSQL is properly configured for remote connections). Is this an antlet issue, and LXC issue, an Antsle issue? Help!

Update: Despite have spent about 6 hours this weekend trying to figure this out, I found the answer about an hour after posting (of course). The solution is to set up port forwarding on the Antsle box itself using libvert, as described here:

(Make sure you replace qemu with lxc as needed.)

Hope this helps someone with the same problem so they don't have to waste 6 hours!

As another option, you can add a bridged NIC to the antlet. This way the antlet can be addressed directly on the local LAN bypassing the internal NAT, port forwarding and nginx.

You can add a NIC to an antlet in the antlet details (click the antlet name in antMan) in the Virtual Network tab.

6 hours. Lucky.  I am on hour 15 at least.  A lot of this is new for me, which is why I don't mind the time.

For my issue, I have yet to try from beyond my internal network. Trying to get from inside the firewall first. Other installations are working (apache, php, etc) on other antlets. There is something I am missing for subsonic.

I just created a brand new antlet with nginx, java and subsonic only.  I have both 4040 and 80 open for it. When I run diagnostics to the port 4040 (which is what subsonic runs on) it shows that it is open, so that isn't the issue. I just get a timeout error when trying either the IP, the antlet name or variations.  Is it possible that the document root is not correct? What other diagnostics might I use to see where the issue is?  What logs can I check?  Timeouts are a bit obtuse.


Just checked the router settings for port forwarding and that is working.  Also checked the subsonic config file and that is set up on port 4040.  Still thinking it may be NGINX needing work.