Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

You need to log in to create posts and topics.

unable to add a NIC to Ubuntu Kubernetes antlet

Has anyone been able to add a NIC to the Ubuntu Kubernetes antlet?  I am able to add the NIC in antMan, but when I power up the antlet, its not visible in ifconfig -a output.

Im trying to set up a Kubernetes cluster with nodes spread across more than one Antsle box.  I would need to add a NIC to each kubernetes node, but seems like it cannot be done on the Ubuntu Kubernetes template.

@chiefspace
First the interface br0,1,2.. must be enabled in antMan > Networking.
Then in the antlet details (click the name of the antlet) > Virtual Network tab select the enabled interface to connect to. Br0 is enabled by default and is a fine choice. Older versions of antMan displayed all interfaces even if not enabled.
The antlet must be Stopped then Started. An OS reboot is not enough.
Then the new bridged vNIC should be visible in the antlet. The interface should be named 'ens8' when using the Ubuntu16.04-Kubernetes template.

Excellent!!! Thank you Mario, I will give this a whirl tonight.  I had switched to a different approach using plain vanilla CentOS7 KVM antlets, 3 of them.

But ran into a road block when I deployed the first rancher container as a way to build the cluster ... just a sort of low expectation run through. Anyway, i will stand up a pair of Ubuntu16 Kub antlets and get to work on the steps you outline in your reply. I am confident that you are correct because i was simply entering the command reboot in the shell thinking that would be good enough.  More updates in a bit.  thanks!

Cool, it worked ... All i really needed to do was edit /etc/network/interfaces and set up the ens8 to dhcp for now.

All set.   I have three Ubuntu16 Kubernetes antlets all running with externally accessible IPs.

Cheers and thanks,

- Ben

Sweet!