Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

Self-managed backup issues

I have a local NAS on my network. I've created an /mnt directory that points to it and I've mounted it.

I created a test LXC antlet and I'm trying to work out the procedure to backup and restore from my local NAS.  The first time I did it, the process completed and the "backups" tab showed that it had been uploaded.  However, it doesn't show up in the NAS directory.  When I try and retrieve it, it says that it was retrieved, but the size is 0.

I then tried to do a second backup of the antlet to the same NAS directory.  The backup started but its status is stuck on 0%.  I deleted the second in-process backup and re-tried, but now the status doesn't show any percentage.

I need some guidance.  Thanks.


Hi @pjhunter

Can you share some screenshots of what you are seeing?

Using SSH in your antlet, can you type in this command:

df -h

This command will show you the mounts and how much space is being used.

Thank you,
antsle Support

Couldn't paste the df results, but included it as a jpg below.

The local NAS has an 8TB drive, about half full.  I've also included a list of the mounts on my antsle (VM2).  Near the bottom is the reference to my NAS drive.  The only thing which is strange about this is that it shows domain=LONGVIEWNAS.  This isn't part of a domain, only a workgroup called "LONGVIEW".  The network name of the NAS device is, in fact, LONGVIEWNAS.  Don't know if this is relevant or not.

Finally, the jpg of "antsle backup tab" shows a couple of interesting things. The first line is the second backup I've tried for this test antlet.  When I filled in the Self-Managed backup popup with "NAS_Backups" as the path and "[email protected]" as the user, a snapshot was taken and the backup status progressed up to 186.2.  Then the snapshot disappears and the status changes to Uploading, but no progress is displayed.  It will stay like this forever until I delete it.

The second line was from yesterday.  Not sure what I did, but it backuped and uploaded.  However the size is 0.  This is the one where when I try to retrieve it, nothing happens.

Hope all this info helps solve this.  Let me know if you need more info.




Uploaded files:
  • Antsle-df-results.jpg
  • antsle-mounts.jpg
  • antsle-backup-tab.jpg

A couple more pieces of info.

I'm not sure how long the last upload process ran, but when I looked this morning the backup status of the antlet showed "Uploaded" but the size was 0.  Furthermore, no file was added the the backup directory.

I've attached 2 more files: the self-managed backup dialog.  Note the destination is "NAS_Backups" which points to //LongviewNAS/Backups/Antsle.  The user is set to admin@LongviewNAS.  LongviewNAS is defined in the /etc/hosts file.  It also doesn't make any difference if I use [email protected].1.7.  The public key for the Antsle was copyied to the NAS device via the ssh-copy-id command.

The current contents of NAS_Backups is shown in the 2nd upload, "antsle_mounts".  There are 3 previously uploaded backups from some time ago.  I seem to recall reading some where when you create the mount point that it should be an empty directory, which NAS_Backups is  not.  The files uploaded there were uploaded from my other Antsle (VM1).  Hard to see how that would make a difference, but I thought I'd mention it.

I have tried self-managed backups from both VM1 and VM2 with the same results.  Both now say antlets are "Uploaded" but with size of 0 and they don't show up on the NAS device.  Both Antsle's are running AntMan 3.4.4

As a side note, I am unable to use the Cloud storage option because I am in a rural environment and my best case upload speed is 3Mbps.  The upload process to the cloud times out after uploading 3-4 GB.  Self-managed local storage is the only practical option for backup.


Uploaded files:
  • antsle-self-managed-dialog.jpg
  • Antsle-mnt-contents.jpg

@daniel-luck, any further thoughts on this issue or should I submit it as a ticket?


Hi @pjhunter

Yes, please submit ticket at so we can have closer look.

antsle Support