Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

Problems accessing a TrippLite UPS in an Win2016Server antlet via USB

So with all the power problems we have in California, I replaced my "dumb" APC battery backup device with a TrippLite LCDT device that connects to a computer via a USB cable.  I thought "no sweat", I'd plug it into my Antsle D+ and get my Win2016Server antlet to monitor it and when the power went out and before the battery died, it would shutdown all the other devices supported by the TrippLite.

I stopped the server antlet, plugged the Tripplite USB cable into the bottom USB port and went to the USB tab of the server antlet.  I noticed one entry that said "TrippLite" so I enabled passthrough on that and restarted the server.

Unfortunately, the TrippLite software could not find the UPS. I tried various things, none worked.  I then unplugged the USB and attempted to restart the antlet, but got a whole host of errors to the effect that "could not find USB device: 6" or something to that effect.  I rebooted the antsle, same error.  Finally, a web search pointed me to "virsh edit {antletname}" and deleting the entries at the bottom of the xml file relating to host devices.  Scary evening into the early morning.

Upon more research, I do not see anywhere folks hooking up a UPS via USB cable to an antlet, only disks, keyboards, etc.  So, my first question (finally) is: Can the USB ports on the Antsle D+ be used for this purpose?  Is there some special configuration needed?


First, I feel your pain with the USB numbers getting renamed with the antsle reboots... I have a Blu-ray drive and a video capture device being passed through to one of my Windows 10 VMs and that's irritating...

Second, I've done some googling and haven't seen anyone doing this for a Windows VM (I found one site where it didn't work using Hyper-V, but nothing about KVM).  Maybe the pass-through doesn't pass-through all the special stuff for UPSs?

Third, I'd personally recommend having the antsle do the monitoring as it can shutdown all the VMs and itself when the battery runs low.  I have a UPS connected but it's not being monitored (I always did it with my physical Windows machines, but never thought of it when I get the antsle -- so thanks for making me think of it!).

I found this:

and am going to experiment with it on mine (I have an APC UPS).

It says it supports Gentoo and, Red Hat (so I'm hoping that means CentOS when I migrate to that... hopefully soon?)