Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

You need to log in to create posts and topics.

No bootable device error from Server 2016 VMWare image

Hello everyone,

I hope someone can give me advice on this issue. I have been trying to get Windows Server 2016 Essentials to load as a KVM on my Antsle for months and keep getting errors. The latest attempt was to create a KVM image from my barely configured virtual machine from VMWare. The process to convert the image file to a KVM on the Antsle went fine. However, when I started it up in Antman, the error I get is "Booting from hard disk.... No bootable device."

Has anyone seen this happen? Any ideas?

Thanks in advance for any help.

Hi @esemtee92,

So you have been importing the .vmdk into an antlet template using our drag-and-drop importer correct?
What bus type and network model were you using?

Hello @will,

I did use the drag-and-drop importer. I kept the bus type as "IDE" and network model as "e1000".

Should I have used the VirtIO drivers for both? I assumed they do not work with Windows based containers.

 

Hi @esemtee92,

Interesting "IDE" and "e1000" are usually the safest bet when importing a VMware VM image to a KVM.

Can you post that antlet's xml? virsh edit antlet_name

@will, I am not sure which directory I should go to to find that info on the Antsle. Is there a specific directory I need to go to?

Wait, I just figured it out. Now, this setup is different because I thought I should at least try a different bus, so I tried the "sata" bus. No change though. I still get the same error.

Here is what I got:

<domain type='kvm'>
<name>HS2016</name>
<uuid>0d736eb1-5db6-4756-b537-5a76b4fe8d9e</uuid>
<memory unit='KiB'>8388608</memory>
<currentMemory unit='KiB'>8388608</currentMemory>
<vcpu placement='static'>2</vcpu>
<os>
<type arch='x86_64' machine='pc-i440fx-2.4'>hvm</type>
<boot dev='hd'/>
</os>
<features>
<acpi/>
<apic/>
<vmport state='off'/>
</features>
<cpu mode='custom' match='exact' check='partial'>
<model fallback='allow'>Westmere</model>
</cpu>
<clock offset='utc'>
<timer name='rtc' tickpolicy='catchup'/>
<timer name='pit' tickpolicy='delay'/>
<timer name='hpet' present='no'/>
</clock>
<on_poweroff>destroy</on_poweroff>
<on_reboot>restart</on_reboot>
<on_crash>restart</on_crash>
<pm>
<suspend-to-mem enabled='no'/>
<suspend-to-disk enabled='no'/>
</pm>
<devices>
<emulator>/usr/bin/qemu-system-x86_64</emulator>
<disk type='file' device='disk'>
<driver name='qemu' type='vmdk'/>
<source file='/antlets/HS2016/HS2016.vmdk'/>
<target dev='sda' bus='sata'/>
<address type='drive' controller='0' bus='0' target='0' unit='0'/>
</disk>
<controller type='usb' index='0' model='ich9-ehci1'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x7'/>
</controller>
<controller type='usb' index='0' model='ich9-uhci1'>
<master startport='0'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0' multifunction='on'/>
</controller>
<controller type='usb' index='0' model='ich9-uhci2'>

<master startport='2'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x1'/>
</controller>
<controller type='usb' index='0' model='ich9-uhci3'>
<master startport='4'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x2'/>
</controller>
<controller type='pci' index='0' model='pci-root'/>
<controller type='ide' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
</controller>
<controller type='sata' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
</controller>
<interface type='network'>
<mac address='b2:61:6e:73:6c:0a'/>
<source network='bblv'/>
<model type='e1000'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
</interface>
<serial type='pty'>
<target port='0'/>
</serial>
<console type='pty'>
<target type='serial' port='0'/>
</console>
<input type='mouse' bus='ps2'/>
<input type='keyboard' bus='ps2'/>
<input type='tablet' bus='usb'>
<address type='usb' bus='0' port='1'/>
</input>
<graphics type='vnc' port='-1' autoport='yes'>
<listen type='address'/>
</graphics>
<sound model='ich6'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
</sound>
<video>
<model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1' primary='yes'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
</video>
<memballoon model='virtio'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/>
</memballoon>
</devices>
</domain>

Interesting.

<disk type='file' device='disk'>
<driver name='qemu' type='vmdk'/>
<source file='/antlets/HS2016/HS2016.vmdk'/>
<target dev='sda' bus='sata'/>

What is the file extension of /antlets/HS2016/HS2016.* in your filesystem? is it actually a .vmdk or .qcow2?

The file extension is .vmdk in the /antlets/_templates/HS2016.kvm directory. Should it have been converted to a .qcow2 extension?