Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Forum breadcrumbs - You are here:ForumGeneral: GeneralNetwrok Config in Antman 2.0
You need to log in to create posts and topics.

Netwrok Config in Antman 2.0

Issues with setting Static address in antman 2.0

1.Auto populate feature does 't work

2. After saving network config there is no reboot popup (not sure if this is still required in antman 2.0)  New network config doesn't take

3. Manual reboot does not fix Network config.

I tried disabling the  interface, rebooting and setting the static IP again with no luck.

Losing critical features is not much of an upgrade.

Hello keith.e,

I will submit a ticket regarding those issues. Thank you for reporting them to us!

Hello @keith-e,

Our developers are taking a look at your reported issue. Would you kindly explain to me (so I can relay it to the development team) what do you mean by "Auto populate feature does 't work"?

Hi @keith-e,

Could you run upgrade-antman and let me know if those issues are resolved on your end? Thank you!


This is a few months old but I am having the same issue.  When I look at the Interfaces section in Antman I see all four of my interfaces IP addresses listed, I noticed that I had fat fingered the BR1 static IP address that I had assigned, I click on Edit for BR1, corrected the IP address and select Save Configuration.  Antman shows success but does not ask me to restart, I restarted anyway (as well as multiple attempts at disabling/enabling the interface, switching from static back to dynamic then back to static etc.) and after it boots back up the interface list still shows the incorrect IP address (as does ifconfig from the console) but if I select Edit on the BR1 interface again in the properties it actually shows the correct IP address that I just entered.  I looked around through the console to try and determine where the network config might be hiding and I was not able to locate it as I was thinking I could probably just go edit it directly there but I am not sure if that is a supported scenario in this case.

Additionally, Antman did not tell me that there was an update available I just happened to see this post and went and ran upgrade-antman and sure enough there was an upgrade available, that does not seem to be how it worked previously, I thought Antman would notify me when you login to the web portal?


Okay so the update did appear to fix this problem but it was not exactly intuitive.  After I updated Antman and made the change described in my post above before restarting this time I went to the Dashboard and there in a big gray bar at the top it said a restart was required, why would this not have appeared on the networking page where you would see it?

After I rebooted there was now a confirm network changes gray bar on the dashboard with a countdown to rollback.  I confirmed the network settings through the console and they were correct this time so I hit confirm and now on the network page everything looks correct.

It would be nice if Antman would tell you about the restart as well as the confirm networking part of the process on the networking page at the time that you actually save the configuration instead of having to navigate back to the dashboard to realize there are additional things that need to be done.  Or for that matter the banner could just display on any page so that there is no way you could miss it.


Anyway, glad my initial issue is resolved.