antsle Forum

Welcome to our antsle community! This forum is to connect all antsle users to post experiences, make user-generated content available for the entire community and more. Please note: If you have specific questions about your antsle and expect a response from our team directly, please continue to use the appropriate channels (email: support@antsle.com) so every inquiry is tracked. 

Forum breadcrumbs - You are here:ForumGeneral: GeneralInstall GhostBSD iso
You need to log in to create posts and topics.

Install GhostBSD iso

Has anyone been able to get GhostBSD to install on their antsle?

KVM shows the following once it extracts and begins to boot off the image

Uploaded files:
  • Clipboard01.png

I've seen that kind of screen before with display driver issues. You might try booting differently and see if they have a "safe" mode equivalent, or change some of the display driver properties. Sorry I can't be more helpful, but I don't have experience with that particular distro.

 

If it's even remotely helpful, I also had the same result. I downloaded GhostBSD and started a KVM container with it. Same garbled screen appeared for me. Definitely some sort of display driver issue.

I've tried a couple boot loader options with no change, but I feel like there's an easy fix for this. I'll take a deeper dive into it when I have a few moments.

Thanks,
Bruce

Hi @akak01000101 --

Got it. Okay, there's something funky about the default X settings in GhostBSD. I found two posts that were illustrative, and combined together, gave me the solution. The posts were:

https://forums.freebsd.org/threads/booting-install-usb-shows-jumbled-graphics.58148/

https://forums.freebsd.org/threads/vidcontrol-missing-modes.55548/

Here's how you get past it:

  1. Reboot the VM and let it start up
  2. At the moment the boot screen comes up, hit "2" to configure boot settings (you'll have like 1 second to hit it, so be quick).
  3. Hit ESC to go into the boot loader prompt. It should respond "OK"
  4. Type set hw.vga.textmode=0 and hit ENTER
  5. Type boot and ENTER
  6. The system should now boot and come up with a usable screen

If you install GhostBSD to disk, you can add that setting to your /boot/loader.conf file.

I haven't done much more experimenting than this right now. Note: about 50% of the time, my mouse isn't working. That may just be my hardware configuration. You might need to muck with it to get the mouse going. Keyboard works fine.

Edit: well, still seems somewhat unstable. Sometimes my keyboard goes away, and sometimes it doesn't. Something's still funky. I'll play with it as time permits. Intermediate goal should be to get a Terminal window open, and you can try issuing some commands to see if that helps (like restart the moused service).

Hope this helps!

Thanks,
Bruce

Thanks Bruce! Apologies for the delay in response.

I got it to boot as you say. But the screen doesn't recognize any keyboard or mouse input. Commands issued from VNC seem to work. I'll keep playing with it. Thanks for helping to get this far.

 

-akak