antsle Forum

Welcome to our antsle community! This forum is to connect all antsle users to post experiences, make user-generated content available for the entire community and more. Please note: If you have specific questions about your antsle and expect a response from our team directly, please continue to use the appropriate channels (email: support@antsle.com) so every inquiry is tracked. 

You need to log in to create posts and topics.

Eliminating unnecessary gettys (Debian LXCs)

If you run Debian LXCs, you may notice that your syslog blows up with many, many lines like these:

Apr 15 08:50:51 nodal.arkane-systems.lan systemd[1]: Stopped Getty on tty3.
Apr 15 08:50:51 nodal.arkane-systems.lan systemd[1]: Started Getty on tty3.
Apr 15 08:50:51 nodal.arkane-systems.lan systemd[1]: Stopped Getty on tty4.
Apr 15 08:50:51 nodal.arkane-systems.lan systemd[1]: Started Getty on tty4.
Apr 15 08:50:51 nodal.arkane-systems.lan agetty[23720]: /dev/tty3: cannot open as standard input: No such file or directory
Apr 15 08:50:51 nodal.arkane-systems.lan agetty[23721]: /dev/tty4: cannot open as standard input: No such file or directory
Apr 15 08:50:52 nodal.arkane-systems.lan systemd[1]: Stopping Getty on tty3...
Apr 15 08:50:52 nodal.arkane-systems.lan systemd[1]: Stopped Getty on tty3.
Apr 15 08:50:56 nodal.arkane-systems.lan systemd[1]: Stopping Getty on tty4...
Apr 15 08:50:56 nodal.arkane-systems.lan systemd[1]: Stopped Getty on tty4.

That's because the default configuration of systemd is to create virtual terminals on the first four ttys, and as you can see if you ls /dev, an antlet only has one tty.

So, to bring this into line, you can run

systemctl disable getty@tty2.service
systemctl disable getty@tty3.service
systemctl disable getty@tty4.service

And to avoid having to restart the antlet, the same commands with "stop" instead of "disable", and presto, no more exploding log files, or CPU time wasted on trying to start the unstartable.

-c