Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

Can't get anything except SuperMicro Screen

Hi Everyone,

I just ran the upgrade-antman script.  After running the script I was getting the NGINX gateway error.  I was still SSHd in so I ran a service antman status.  It returned Status: Crashed.
I tried restarting the service, but it would just crash.  I tried the step from this post: https://antsle.com/forum/topic/502-bad-gateway-after-setting-up-instantssl/ about running antsleOS-logs antman and service antman restart at the same time in different tabs.  I did not see any errors in the logs, but I still saw that the service had a status of Crashed.
I tried restarting the whole system, but now all I get is the SuperMicro login screen.  I can log in on the supermicro screen and use the iKVM/HTML5 console to log in, but I can't SSH into the system via the command line anymore.  I still can't seem to get the normal Antsle login screen and I'd like to get back to working on my Antlets.  At this point, I'm feeling pretty stuck and hoping anyone can help.
Thank you in advance!

Are you getting any errors trying to ssh to the antsle or does it just time out?

If you can login via the IPMI (SuperMicro) screen, what happens if you do:

service sshd status [or, if you're on the new edgeLinux 2.0, systemctl status sshd.service]

service sshd restart [or, systemctl restart sshd.service]

Does antman work using the IP address? [ http://{antsle-ip-address}:3000 ]

If antman works, can you go to the Services menu on the left and is everything running?

 

Thanks for the reply lancem!  I tried it today and couldn't even get the IPMI screen.  I plugged a mouse and keyboard in and here is what I found:

service sshd status returned started

service sshd restart ran without errors, but still did not change anything.

Here is some extra info that may be helpful:

antsleOS-version: 0.5.0 - I've been trying to find out what the most recent version is because I don't think this is it...
br0 DID get an IP address assigned, but I can't ssh - It refused connection on port 22.
I DO also have internet, I was able to successfully ping google.com and antsle.com - I tried the upgrade-antman script again and it says success but service antman status returns crashed.

The current gentoo version is 0.12.1 (I think you have to upgrade-edgelinux 0.12.0 first, then upgrade-edgelinux 0.12.1)

Maybe there's a compatibility issue between the new antman and that version of antsleOS/edgelinux?

And your doing the ssh using the IP address (and not the name)?

What about:

netstat -a|grep 22

(to see if anything is listening on port 22)

 

Hi lancem!

Upgrading edgelinux seemed to do the trick.  Thank you so much for all the help you gave me!