antsle Forum

Welcome to our antsle community! This forum is to connect all antsle users to post experiences, make user-generated content available for the entire community and more. Please note: If you have specific questions about your antsle and expect a response from our team directly, please continue to use the appropriate channels (email: support@antsle.com) so every inquiry is tracked. 

You need to log in to create posts and topics.

Antsle: Not Ready for Prime Time

We just tried the so-called upgrade. What a total train wreck. There's something to be said for eating your own dog food before you foist it on the public, much less business customers. The good news is it certainly made the decision on whether to take advantage of the 30-day money-back guarantee easy.

Here's how the upgrade is progressing so far:

2019-05-05 06:36:24 (2.79 MB/s) - ‘/antlets/_edgeLinux-workspace/edgeLinux-0.12.0-avoton.tar.gz’ saved [2083841908/2083841908]

* Last emerge --sync was 31d 10h 4m 23s ago.

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-libs/readline:0

(sys-libs/readline-7.0_p5:0/7::gentoo, binary scheduled for merge) conflicts with

sys-libs/readline:0/0=[abi_x86_64(-)] required by (dev-db/sqlite-3.19.3:3/3::gentoo, binary scheduled for merge)

^^^^^

!!! The following update has been skipped due to unsatisfied dependencies:

net-fs/samba:0

selected: (net-fs/samba-4.5.16:0/0::gentoo, ebuild scheduled for merge)

skipped: (net-fs/samba-4.8.6-r2:0/0::gentoo, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=dev-util/cmocka-1.1.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" have been masked.

!!! One of the following masked packages is required to complete your request:

- dev-util/cmocka-1.1.5::gentoo (masked by: EAPI 7)

- dev-util/cmocka-1.1.3::gentoo (masked by: EAPI 7)

- dev-util/cmocka-1.1.3 (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a

newer version of portage before EAPI masked packages can be installed.

(dependency required by "net-fs/samba-4.8.6-r2::gentoo" [ebuild])

For more information, see the MASKED PACKAGES section in the emerge

man page or refer to the Gentoo Handbook.

!!! The following update has been skipped due to unsatisfied dependencies:

sys-libs/glibc:2.2

selected: (sys-libs/glibc-2.27-r6:2.2/2.2::gentoo, binary scheduled for merge)

skipped: (sys-libs/glibc-2.28-r5:2.2/2.2::gentoo, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=net-dns/libidn2-2.0.5" have been masked.

!!! One of the following masked packages is required to complete your request:

- net-dns/libidn2-2.1.1a::gentoo (masked by: EAPI 7)

- net-dns/libidn2-2.1.1a (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a

newer version of portage before EAPI masked packages can be installed.

(dependency required by "sys-libs/glibc-2.28-r5::gentoo[-test]" [ebuild])

For more information, see the MASKED PACKAGES section in the emerge

man page or refer to the Gentoo Handbook.

!!! The following update(s) have been skipped due to unsatisfied dependencies

!!! triggered by backtracking:

app-shells/bash:0

!!! Problems have been detected with your world file

!!! Please run emaint --check world

!!! Ebuilds for the following packages are either all

!!! masked or don't exist:

app-crypt/certbot-nginx dev-python/cryptography app-admin/eclean-kernel

!!! 'sys-fs/eudev' (virtual/dev-manager) is part of your system profile.

!!! Unmerging it may be damaging to your system.

* After world updates, it is important to remove obsolete packages with

* emerge --depclean. Refer to `man emerge` for more information.

python-exec: Invalid impl in /etc/python-exec/python-exec.conf: python3.4

* Last emerge --sync was 31d 11h 58m 3s ago.

!!! The following binary packages have been ignored due to changed dependencies:

     dev-python/python3-lxc-3.0.2::gentoo

     app-emulation/qemu-3.1.0-r1::gentoo

     app-text/openjade-1.3.2-r8::gentoo

     app-emulation/lxc-templates-3.0.3::gentoo

     x11-misc/makedepend-1.0.5-r1::gentoo

     app-admin/eclean-kernel-0.4.3::gentoo

     sys-apps/dbus-1.12.12-r1::gentoo

     net-misc/curl-7.64.1::gentoo

     dev-python/future-0.17.0::gentoo

     dev-python/setuptools-40.8.0::gentoo

     dev-libs/libtasn1-4.13::gentoo

     dev-lang/nasm-2.14.02::gentoo

     net-dns/libidn2-2.1.1a::gentoo

     net-libs/gnutls-3.6.7::gentoo

     dev-db/sqlite-3.25.3::gentoo

     net-dns/dnsmasq-2.80::gentoo

     dev-libs/nettle-3.4.1::gentoo

     app-emulation/lxc-3.0.3::gentoo

     dev-util/cmocka-1.1.3::gentoo

     dev-libs/nspr-4.20::gentoo

NOTE: The --binpkg-changed-deps=n option will prevent emerge

      from ignoring these binary packages if possible.

      Using --binpkg-changed-deps=y will silence this warning.

 

Have you contacted support?

My upgrade went thru...it tossed out all kinds of errors similar to above.  In fact ultimately the last messages were about unmerging the antman package.  It was a yes or no....not knowing exactly what to do with that I answered yes assuming that it was abotu to be replaced with an updated version or some such.  That resulted in messages about the upgrade having failed or that seemed to be what it indicated anyway.  Then the system rebooted.

After the reboot the system had no network.  I fiddled with the network connections plugging and unplugging until I got a ping response.  The upgrade seems to indicate the right versions in "about" of the antman web interface. 0.12.0 now.  However as best as I can see it the upgrade seems to have entirely remapped the network connections.

BR-0 seems to be a different port now.  In fact plugging something into the indicated normal BR-0 kills the network connection to the system.

See Included Picture:  The BR-0 as pictured has no network cable plugged into it.  Best I can figure out is BR-o is now the port above it...labeled BR-2

Uploaded files:
  • post-upgrade.png

Hi @haplopeart,

I can't seem to replicate the remapping of the networking connections here or our antsles. What type of antsle are you running on? antsle one, antsle one XD Pro, etc?

We contacted Mr. Mundy directly, and are working on some on the conflicts that show up in the upgrade, but as you pointed out the upgrade does still go through on the systems we have seen.

Antsle One...purchased in February 2017 if it matters.

 

Now that the 0.12.0 seems to be OK-ish...the box is working and my antlets are communicating, I'm re-running the upgrade and its moving to 0.12.1...maybe things will be more right after that?

For the record the 0.12.1 upgrade seemed to proceed...MUCH smoother!  I have not yet rebooted the box (it didn't ask for it)...but will tomorrow and see if the network is in better shape.

Ok thanks for letting me know. Yeah 0.12.0 to 0.12.1 does not require a kernel upgrade hence you shouldn't have to reboot it.