antsle Forum

Welcome to our antsle community! This forum is to connect all antsle users to post experiences, make user-generated content available for the entire community and more. Please note: If you have specific questions about your antsle and expect a response from our team directly, please continue to use the appropriate channels (email: so every inquiry is tracked. 

You need to log in to create posts and topics.

Antsle NIC MAC addresses keep changing!!

I'd like to use DHCP for my antsle br0 (currently only using the 1 network interface), but every time I restart the unit, it gets a different MAC address.   (My network monitor (FingBox) also keeps griping that a new device has joined the network)

Is there any way to make the physical NICs keep the same MAC address?

Are you sure you are not seeing the MAC address of a virtual machine behind the bridge? Because the hardware MAC of the Antsle itself should not be changing. Can you post some examples of the MAC you are seeing? If it starts with 52:54:00 then it is almost certainly one that is being generated by libvirt, not a hardware MAC.

Attached are some screenshots of what my network reports as its MAC address when I reboot (and it connects to the network).

The antsle unit has a static IP of

Currently, if I get on the antsle console and do ip addr, it shows:

8: br0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 3a:d3:1a:0b:7a:ea brd ff:ff:ff:ff:ff:ff
inet brd scope global br0
valid_lft forever preferred_lft forever
inet6 2600:8804:6100:5df:38d3:1aff:fe0b:7aea/64 scope global mngtmpaddr dynamic
valid_lft 67746sec preferred_lft 67746secinet6 fe80::ae1f:6bff:fe49:836c/64 scope link
valid_lft forever preferred_lft forever


That MAC matches the first screenshot:

SmartSelect_20181208-140450_Fing - Copy.jpg

Uploaded files:
  • SmartSelect_20181208-140450_Fing-Copy.jpg
  • SmartSelect_20181208-140519_Fing-Copy.jpg
  • SmartSelect_20181208-140618_Fing-Copy.jpg
  • SmartSelect_20181208-140704_Fing-Copy.jpg
  • SmartSelect_20181208-140735_Fing-Copy.jpg

Indeed, all of those MAC addresses have bit 1 set and bit 0 cleared in the left-most octet, which means "locally administered unicast".

IOW, they are probably all generated for a virtual interface. The Antsle, like most virtualization platforms, has in internal software bridge (switch) that the various VM's connect to. The external Ethernet is also connected to the same bridge. That is how VM's are connected to the outside world.

Apparently, by default a bridge device (e.g. our br0) will get assigned the lowest MAC of all the interfaces connected to it, but the virtual interfaces are generated semi-randomly. In fact it seems the bridge MAC can change as VM's are started and stopped! This is something I did not know even though I've used Linux bridging a few times.

The fix is to manually assign a MAC, such as the one from the actual phsyical NIC connected to the bridge. I'm not familiar enough with Gentoo to know how to do this (I'm a Debian guy), and also I'm not sure how the configuration files interact with AntMan. I suggest contacting support to see if they can help, but maybe this will get you started:

It might be good for Antsle to set it up that way by default if they are going to support DHCP, or else allow us to set the MAC address from AntMan. Time for a feature request I guess.

Thanks, @bobh.  That points me in a direction!


I contacted support.  They directed me to enable "antAid", which allows them to connect to my Antsle.

*Note that this requires you provide them your Antsle's root password.  I did as they recommended and changed it to something just for them, then changed it back after they were done.

In their words:

"I added a line to the '/etc/conf.d/net' file to set the MAC address to the correct MAC.
But this will require a reboot so I'll let you do that since you have your antlets running right now.

This configuration will be overwritten if you make changes to the network configuration in antMan.

Its a simple addition of the line

mac_br0="{mac address here}"

The bridge should be using the same MAC as the physical interface - enp0s20f0 in this case.

Our developers will be working on a fix for this to be in the next release of antMan"

I rebooted the Antsle and the MAC stayed!