Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Forum breadcrumbs - You are here:ForumGeneral: How-To GuidesOpenVPN
You need to log in to create posts and topics.

OpenVPN

I tried to follow the FreedomCast to install an OpenVPN antlet on my new Antsle. It does not apply anymore. The message is from the install of OpenVPN...it requires a newer version of Debian. However, when I tried to use newer version of Debian, other stuff was missing. I even tried other flavors of Linux and had other problems.

Can someone give updated instructions on getting the current version of OpenVPN up and running?

Hey @djurden,

We don't have updated instructions at the moment but are working on coming out with a new video to detail those. I'm sorry for the inconvenience.

If you can reply with exactly where you got stuck, we can do our best to help you out on this community forum.

One other thing to make sure of is that you're using the Debian_8.5 LXC template.

Best,

Haley

Ok...I'll start over. I'll start with Debian 8.5 and let you know where I get stuck.

@haley

Started with Debian 8.5. Installed updates....then upgrade.

Edited my /etc/network/interfaces file setting eth1 with a static ip address and rebooted.

Ifconfig shows correct  settings. I can ping internal and external ip addresses.

I installed the wpget command.

Got the openvpn-install.sh.

Then when I run "bash openvpn-install.sh", I get a message saying "Debian 8 is too old and not supported."

 

@djurden
I was able to get openvpn installed using Debian10-lcx. I followed the portion of the video until bash openvpn-install.sh. I had to enable tun and install iptables on my antlet before I could proceed. I didnt have a net/tun directory so I created that using a startup script.

Created a startup script:

/usr/sbin/tunscript.sh

#!/bin/bash
mkdir /dev/net
mknod /dev/net/tun c 10 200
chmod 0666 /dev/net/tun

Made the script executable.
Add it to /etc/rc.local

/usr/sbin/tunscript.sh || exit 1

Install iptables and then reboot.
I ran
bash openvpn-install.sh and it created everything without issue.

I have used this often, on an older Antsle ONE that I installed OpenVPN via Bernie's video and it worked great for years. Now that I have had to purchase a new Antsle One D, I am getting the same issues as most of you.  Not because of the One D, just time catching up.  I was able to get it installed using the Debian9.9.kvm template without the need to configure tun as it was already there.

My issue now is I cannot connect to the OpenVPN server.  My OpenVPN client just clocks at "no route to host"

I have set the proper port forwarding on my router... no dice.
I have set the router to forward 1194 udp to the Antsle IP on my network, and used Port Forwarding inside Antman to send 1194 to the antsle...no dice
I have set the server to use the 10.1.1.x address of the antsle...no dice
I have set the server to use the 192.168.x.x address of my network...no dice.

I am at a loss.  It's the last server I need to move or rebuild on my One D and it is driving me to drink.

I've tried backing up the old server, and restoring to the new server... but issues with that make it unlikely to get completed anytime soon.

My One D is on edgeLinux 2.0.0 and andMan 3.0.1 where my old Antsle One is on edgeLinux 0.12.1 and andMan2.2.1a

I'm open for advice as I am running out of drink.

-Cheers