Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Forum breadcrumbs - You are here:ForumGeneral: How-To GuidesOpenVPN
Please or Register to create posts and topics.


Page 1 of 2Next

I tried to follow the FreedomCast to install an OpenVPN antlet on my new Antsle. It does not apply anymore. The message is from the install of requires a newer version of Debian. However, when I tried to use newer version of Debian, other stuff was missing. I even tried other flavors of Linux and had other problems.

Can someone give updated instructions on getting the current version of OpenVPN up and running?

Hey @djurden,

We don't have updated instructions at the moment but are working on coming out with a new video to detail those. I'm sorry for the inconvenience.

If you can reply with exactly where you got stuck, we can do our best to help you out on this community forum.

One other thing to make sure of is that you're using the Debian_8.5 LXC template.



Ok...I'll start over. I'll start with Debian 8.5 and let you know where I get stuck.


Started with Debian 8.5. Installed updates....then upgrade.

Edited my /etc/network/interfaces file setting eth1 with a static ip address and rebooted.

Ifconfig shows correct  settings. I can ping internal and external ip addresses.

I installed the wpget command.

Got the

Then when I run "bash", I get a message saying "Debian 8 is too old and not supported."


I was able to get openvpn installed using Debian10-lcx. I followed the portion of the video until bash I had to enable tun and install iptables on my antlet before I could proceed. I didnt have a net/tun directory so I created that using a startup script.

Created a startup script:


mkdir /dev/net
mknod /dev/net/tun c 10 200
chmod 0666 /dev/net/tun

Made the script executable.
Add it to /etc/rc.local

/usr/sbin/ || exit 1

Install iptables and then reboot.
I ran
bash and it created everything without issue.

I have used this often, on an older Antsle ONE that I installed OpenVPN via Bernie's video and it worked great for years. Now that I have had to purchase a new Antsle One D, I am getting the same issues as most of you.  Not because of the One D, just time catching up.  I was able to get it installed using the Debian9.9.kvm template without the need to configure tun as it was already there.

My issue now is I cannot connect to the OpenVPN server.  My OpenVPN client just clocks at "no route to host"

I have set the proper port forwarding on my router... no dice.
I have set the router to forward 1194 udp to the Antsle IP on my network, and used Port Forwarding inside Antman to send 1194 to the dice
I have set the server to use the 10.1.1.x address of the dice
I have set the server to use the 192.168.x.x address of my dice.

I am at a loss.  It's the last server I need to move or rebuild on my One D and it is driving me to drink.

I've tried backing up the old server, and restoring to the new server... but issues with that make it unlikely to get completed anytime soon.

My One D is on edgeLinux 2.0.0 and andMan 3.0.1 where my old Antsle One is on edgeLinux 0.12.1 and andMan2.2.1a

I'm open for advice as I am running out of drink.


Has anyone gotten this to work?  My goal is to be able to VPN in and be able to display the antsle console on port 3000.

I have been able to get everything installed - and I can connect a VPN client, however, I must not have the correct routing set up.

My VPN IP is 10.8.0.x

The OpenVPN Server sits on

My home network is 192.168.86.x

Any help is greatly appreciated.


I recall getting that No Route To Host error when the network I was connecting to used the same IP scheme as the one I was currently on.

For example, my home network and my wife's clinic network were both 192.168.86.x.  And I couldn't VPN into her VPN server from home, but it would work from elsewhere.

So I change my IP scheme at home to 192.168.80.x (it was less painful).

I'm using OpenVPN on a CentOS VM at 3 locations (home, in-laws, clinic).

Some info I recall having to mess with to get it to work:

On my VPN server, the /etc/resolve.conf is:

search lan

nameserver [the router address at the VPN server's location]

And some lines from my /etc/openvpn/server.conf:

#push "dhcp-option DNS" [I commented this line out]

push "dhcp-option DNS" [the router at the server's location]

push "redirect-gateway def1 bypass-dhcp"

push "route" [the network addresses at the server's location]

push "route"  [the antlets' network range]

I emphasize in the file above that the 192.168.80.x stuff is the DHCP info on the VPN server's network.

Also, when I VPN to a location, I have to add .lan to the end of device names [example: I RDP to RECEPTION.lan, not RECEPTION]

Also also: To get the VPN service to even come up, I had to add this to the XML config for the vpn antlet (virsh -c lxc:/// edit {antletName})

<hostdev mode='capabilities' type='misc'>

per this site:


Great Thanks for sharing

We may try again again. I'll begin using Debian 8.5 and report back if I run into any problems.

drift hunters

daniel.luck has reacted to this post.
Page 1 of 2Next