Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Forum breadcrumbs - You are here:ForumGeneral: edgeLinux/antManHelp with upgrade
You need to log in to create posts and topics.

Help with upgrade

I'm stuck with the upgrade.

After trying upgrade-edgelinux script, it gets stuck on the emerge

How do I move forward?

* Last emerge --sync was 148d 15h 27m 13s ago.

* IMPORTANT: 3 config files in '/etc/portage' need updating.

* See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS

* sections of the emerge man page to learn how to update config files.

!!! Problems have been detected with your world file

!!! Please run emaint --check world

!!! Ebuilds for the following packages are either all

!!! masked or don't exist:

app-admin/eclean-kernel

!!! All ebuilds that could satisfy ">=dev-util/cmocka-1.1.1[abi_x86_64(-)]" have been masked.

!!! One of the following masked packages is required to complete your request:

- dev-util/cmocka-1.1.5::gentoo (masked by: EAPI 7)

- dev-util/cmocka-1.1.3::gentoo (masked by: EAPI 7)

- dev-util/cmocka-1.1.3 (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a

newer version of portage before EAPI masked packages can be installed.

(dependency required by "net-fs/samba-4.8.6-r2::gentoo" [binary])

(dependency required by "net-fs/cifs-utils-6.7::gentoo" [binary])

(dependency required by "@selected" [set])

(dependency required by "@world" [argument])

For more information, see the MASKED PACKAGES section in the emerge

man page or refer to the Gentoo Handbook.

* Failed to emerge @world, aborting. 

Error while upgrading edgeLinux

 

 

Have you done what it is saying you need to do so it can forward?

!!! Please run ”emaint --check world”

I would try that.

Hi Doug,

Yes, I did...

root@ant:~ # emaint --check world

Emaint: check world        100% [===========================================>]

'sys-fs/squashfs-tools' is not installed

'sys-apps/lshw' is not installed

'sys-fs/lxcfs' is not installed

'app-arch/deb2targz' is not installed

'app-admin/sudo' is not installed

'sys-fs/udev' is not installed

'app-admin/eclean-kernel' is not installed

'sys-apps/cpuid' is not installed

'sys-kernel/gentoo-sources' is not installed

'net-misc/bridge-utils' is not installed

'sys-apps/lm_sensors' is not installed

'app-crypt/certbot-nginx' is not installed

'app-cdr/cdrtools' is not installed

'sys-kernel/gentoo-sources:4.14.83' is not installed

'app-emulation/runc' is not installed

'sys-apps/ethtool' is not installed

'net-misc/iperf:3' is not installed

'sys-fs/ncdu' is not installed

'net-analyzer/tcpdump' is not installed

'net-misc/iperf:2' is not installed

and then I've tried the upgrade again, with the same result.

I've also tried to do an emerge --sync manually, but it complains I don't have the latest portage (7 if I remember correctly).

After that, I've also tried to emerge portage but it is unable to install/upgrade that either.

I'm completely stuck.

Did open a support ticker but I have no support plan so they are just ignoring me.

Anyway, I appreciate your reply, if you think of something please do let me know.

Cheers

Just spoke with our tech guys, they replied directly. We're on this

Quote from Johannes Dietzel on September 4, 2019, 2:57 pm

Just spoke with our tech guys, they replied directly. We're on this

Thanks, Johannes.

Did get the email with the instructions, much appreciated.

I'll report back as soon as I apply them.

Cheers

Big Kudos to the support team!!!

Not only they gave a way out of my stuck upgrade but they also followed up and helped me with some cleanup.

In essence, they gave me a script to download and install edgelinux 0.12.1 directly on top of my 0.5 (if I remember correctly) and then helped me with some cleanup and configuration.

I always wondered if they would actually provide support since I only bought the hardware and have no subscription.

After opening a support ticket, they responded within about 5 days, note that my situation was not urgent since my antlets were still working.

I followed their instructions and sent them some issues I was having and they followed up to solve them.

Cheers folks

Glad to see you had a similar experience with them.  They have been really good with me as well so I am appreciative of their tech support.

powered by proof factor - increase conversions with social proof notifications