Windows11 Template: Could not define libvirt domain

11 repliesPage 1 of 2
akak01000101
68 posts

I'm trying to use the Antsle provided "Win11StdGui - KVM" template and when trying to create and antlet get the error "1 Could not define libvirt domain for antlet xxxxxx

edgeLinux version: 0.12.1

Antman: 3.3.1

Any thoughts?

lancem
210 posts

I get that error if I try to create an antlet with the same name as either an existing antlet or an existing zfs filesystem (like antlets/oldname)

daniel.luckStaff
551 posts

Hi @lancem:

Thanks for sharing!

Yes, I've seen that error before when create an antlet with same name and even the same IP Address.

The template has been tested with edgeLinux 2.0 (CentOS-based) and older edgeLinux 0.12.0 and lower (Gentoo-based).

akak01000101
68 posts

Any other ideas?

I tried to create the antlet with a unique name never used before with an IP that has never been allocated to any other antlet as well.

daniel.luckStaff
551 posts

Hi @akak01000101

You can also try upgrading to the latest antMan (3.4.2) by using this command in the SSH or Console of your antsle:
upgrade-antman

daniel.luckStaff
551 posts

Hi @akak01000101

There was an issue with the definition of this template for Gentoo-based edgeLinux (0.12 and lower).  The issue has been now fixed.

You can remove the template and re-download the template.  It should work now.

akak01000101
68 posts

Hi Daniel,

I deleted the template through antman, but now I don't see any Windows 11 Templates listed to download. Is there anything that needs to be cleared or manually cleaned up?

daniel.luckStaff
551 postsedited

Hi @akak01000101

Sorry, I forgot to mention.  There's a bug in antMan where the templates you have deleted may not show up.

You can connect to your antsle with SSH or Console, and use this command to restart antMan:
service antman restart

After some time, try to reload antMan in your browser.  The template you just deleted should now show up.

akak01000101
68 posts

I downloaded the template (Win11StdGui - KVM) and received the same error.

I attempted to upgrade to 3.4.2 and I received a license error that I need purchased support to upgrade antman. I upgraded multiple times in the past. Do antman upgrades require a subscription now or is something possibly broken broken?  Antsle engineers have been in my box multiple times to resolve several issues.

* Failed to install antman license: [ !! ]
* You are not subscribed to upgrade. Please go to https://antsle.com/pricing to purchase a plan. [ !! ]
Error while upgrading antman
* WARNING: antman has already been started

daniel.luckStaff
551 posts

Hi @akak01000101:

If you're on antsle hardware, then you'll be on Home Lab license even without a subscription.
If you're on non-antsle hardware, you'll need a subscription to use antMan.

In both cases, you should have access to upgrade to the latest antMan.

Can you let us know your serial number so we can better assist you?  If you'd like, you can also send an e-mail to [email protected] as well.

Log in to reply. New here? It takes a minute.