Update to 0.12.0 fails on emerge

1 reply
barduino
20 posts

Hi Folks, any help appreciated, I'm at a loss here.

I'm trying to upgrade edge linux to 0.12.0 and after the backup I get an error with the emerge

!!! Ebuilds for the following packages are either all

!!! masked or don't exist:

app-admin/eclean-kernel

!!! All ebuilds that could satisfy ">=dev-util/cmocka-1.1.1[abi_x86_64(-)]" have been masked.

!!! One of the following masked packages is required to complete your request:

- dev-util/cmocka-1.1.5::gentoo (masked by: EAPI 7)

- dev-util/cmocka-1.1.3::gentoo (masked by: EAPI 7)

- dev-util/cmocka-1.1.3 (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a

newer version of portage before EAPI masked packages can be installed.

(dependency required by "net-fs/samba-4.8.6-r2::gentoo" [binary])

(dependency required by "net-fs/cifs-utils-6.7::gentoo" [binary])

(dependency required by "@selected" [set])

(dependency required by "@world" [argument])

For more information, see the MASKED PACKAGES section in the emerge

man page or refer to the Gentoo Handbook.

* Failed to emerge @world, aborting.                                                                                                     [ !! ]

Error while upgrading edgeLinux

Not sure what to do, emerge has never worked for me...

Former member

Hello barduino,

I have submitted a ticket on this issue. Please be assured that our developers and support team will take a look at this as soon as possible. Thank you for your support of Antsle.

Log in to reply. New here? It takes a minute.