Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

You need to log in to create posts and topics.

Can't get virtual NIC to work.

I'm having trouble getting a virtual interface to work on a CentOS machine. I have followed the instructions in the support documents to no avail. I have created the ifcfg-eth1 file but when I try to restart the network services, I get the following output.

[[email protected] network-scripts]# systemctl restart networkAuthorization not available. Check if polkit service is running or see debug message for more information.Job for network.service failed because the control process exited with error code. See "systemctl status network.service" and "journalctl -xe" for details.

When i run journalctl -xe, I see the following entries:

Mar 30 15:44:44 antlet10 network[20271]: Bringing up interface eth1: ERROR : [/etc/sysconfig/network-scripts/ifup-eth] Device [email protected] does not seem to be present, delaying initialization.

Mar 30 15:44:44 antlet10 /etc/sysconfig/network-scripts/ifup-eth[20442]: Device [email protected] does not seem to be present, delaying initialization.

Why can't it find my eth1 interface.

Help!

Hey @gregh825,

I created a CentOS-7.1 - LXC, created a vNIC in antMan, started the antlet, and  sshed in.

Run

cp /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth1

Then edited `ifcfg-eth1` to `DEVICE=eth1`.

Now `service network restart` and I can see the new ip on eth1 when I run an ifconfig.

You can then update the OS if you like.

 

Are you perhaps using a different CentOS than the templates or not using the LXC version?

 

That fixed it.

Thanks!!!

powered by proof factor - increase conversions with social proof notifications