Antsle Forum

Welcome to our Antsle community! This forum is to connect all Antsle users to post experiences, make user-generated content available for the entire community and more. 

Please note: This forum is about discussing one specific issue at a time. No generalizations. No judgments. Please check the Forum Rules before posting. If you have specific questions about your Antsle and expect a response from our team directly, please continue to use the appropriate channels (email: [email protected]) so every inquiry is tracked. 

Please or Register to create posts and topics.

Can't create antlets & Can't update edgelinux

Hi, I hope everyone is doing great!

I am new to edgelinux, I was able to install it on a dell server 2TB and 32 GB ram.

Then, I tried to create an antlet, while i was trying to select a win 10 image (or any image) had this message:

CTZFS-1: Error when trying to zfs create. The ZFS modules are not loaded. Try running '/sbin/modprobe zfs' as root to load them.

After running '/sbin/modprobe zfs' I have this message:

modprobe: FATAL: Module zfs not found.

Then I tried to upgrade using upgrade-edgelinux and have this message:

--2020-05-01 12:29:39-- http://central.antsle.com/edgeLinux-releases/0.12.1/elupd-0.12.1
Resolving central.antsle.com (central.antsle.com)... 147.75.49.34
Connecting to central.antsle.com (central.antsle.com)|147.75.49.34|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7158 (7.0K) [application/octet-stream]
Saving to: ‘elupd-0.12.1’

100%[======================================>] 7,158 --.-K/s in 0.002s

2020-05-01 12:29:40 (3.44 MB/s) - ‘elupd-0.12.1’ saved [7158/7158]

./elupd-0.12.1: line 11: /lib64/gentoo/functions.sh: No such file or directory
./elupd-0.12.1: line 19: eend: command not found
Error while upgrading edgeLinux

Any help will be really appreciated!!

Take Care!

Hi @cbar126

There's a known issue with the latest centos kernel released last week. We have pushed a hotfix in our ISO on Tuesday. Right now, a workaround is using the previous kernel until we push a complete edgeLinux update.

The message when running the upgrade-edgelinux command is wrong, 0.12.1 should be for our previous gentoo-based OS; We'll update it!

I think the kernel is causing issues so I'm just gonna reload..

Can you give instructions on reloading the Kernel?

Quote from cbar126 on May 1, 2020, 9:44 am

Hi, I hope everyone is doing great!

I am new to edgelinux, I was able to install it on a dell server 2TB and 32 GB ram.

Then, I tried to create an antlet, while i was trying to select a win 10 image (or any image) had this message:

CTZFS-1: Error when trying to zfs create. The ZFS modules are not loaded. Try running '/sbin/modprobe zfs' as root to load them.

After running '/sbin/modprobe zfs' I have this message:

modprobe: FATAL: Module zfs not found.

Then I tried to upgrade using upgrade-edgelinux and have this message:

--2020-05-01 12:29:39-- http://central.antsle.com/edgeLinux-releases/0.12.1/elupd-0.12.1
Resolving central.antsle.com (central.antsle.com)... 147.75.49.34
Connecting to central.antsle.com (central.antsle.com)|147.75.49.34|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7158 (7.0K) [application/octet-stream]
Saving to: ‘elupd-0.12.1’

100%[======================================>] 7,158 --.-K/s in 0.002s

2020-05-01 12:29:40 (3.44 MB/s) - ‘elupd-0.12.1’ saved [7158/7158]

./elupd-0.12.1: line 11: /lib64/gentoo/functions.sh: No such file or directory
./elupd-0.12.1: line 19: eend: command not found
Error while upgrading edgeLinux

Any help will be really appreciated!!

Take Care!

Hi,

Hard reboot will help!

love

Jackie

I am trying to reload as well, but the link to download the edge linux iso isn't working. Is anyone else experiencing that? Does anyone have a copy of edge linux I could get a copy of?

Ok, I managed to get it installed and running. After the ISO install (you can get that from anthill.antsle.com, you'll need another account), I had to do 'yum install ansible', and then in /opt/elinstaller there is a script 'managed-install-local'. Run that and it'll fully configure edgelinux and antman.

Hope this helps!